编程是一门艺术

raptor.zh(at)gmail.com Creative Commons License
本作品采用知识共享署名-非商业性使用-相同方式共享 2.5 中国大陆许可协议进行许可。

archives 存档

01 Jan - 31 Dec 2018
01 Jan - 31 Dec 2017
01 Jan - 31 Dec 2016
01 Jan - 31 Dec 2015
01 Jan - 31 Dec 2014
01 Jan - 31 Dec 2013
01 Jan - 31 Dec 2012
01 Jan - 31 Dec 2011
01 Jan - 31 Dec 2010
01 Jan - 31 Dec 2009
01 Jan - 31 Dec 2008
01 Jan - 31 Dec 2007
01 Jan - 31 Dec 2006
01 Jan - 31 Dec 2005
01 Jan - 31 Dec 2004
01 Jan - 31 Dec 2003
01 Jan - 31 Dec 2002
01 Jan - 31 Dec 2001
01 Jan - 31 Dec 2000
01 Jan - 31 Dec 1999

--

links 链接

--

FreeBSD里docker无版本号问题的处理

发现

按照《在FreeBSD上使用Docker》的做法安装成功了Docker,但是因为要用docker-compose,结果报错了,说找不到合适版本的docker,可是我明明装了。

docker -v

居然报版本号为unknown-version:

Docker version unknown-version, build unknown-commit

删除后重装最新版仍然如此,而且不论是用ports还是用pkgng安装都是这样。

只能自己想办法了。

解决

在ports里搜索了一下源码,发现版本信息是配置在cli/cli/version.go这个文件里,但是直接改这个文件是没用的。

研究了一番发现,唯一的办法是给ports打patch。

在files文件夹里创建一个文件patch-components_cli_cli_version.go,内容为:

--- components/cli/cli/version.go.orig  2018-09-27 08:03:45 UTC
+++ components/cli/cli/version.go
@@ -4,7 +4,7 @@ package cli
 // These values are overridden via ldflags
 var (
        PlatformName = ""
-       Version      = "unknown-version"
+       Version      = "18.06.0"
        GitCommit    = "unknown-commit"
        BuildTime    = "unknown-buildtime"
 )

再安装一下:

make install clean

现在docker的版本号就正常了,docker-compose也可以正常使用了。

推送到[go4pro.org]

Trackback link:

Please enable javascript to generate a trackback url

No trackbacks

评论(0)


 
   
 
  表情图标 

 


提示: 除了 <b> 和 <i> 之外,其他的Html标签都将从您的评论中去除.url或mail地址会被自动加上链接.